Grails 2.3.9 - Error: ClassNotFoundException: grails.plugin.spock.test.GrailsSpecTestType

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Grails 2.3.9 - Error: ClassNotFoundException: grails.plugin.spock.test.GrailsSpecTestType

Igor Alves
Hello there,

I wonder if someone can help me with this:

Whenever I enter the grails command: test-app I get this error:

    Error executing script TestApp: java.lang.ClassNotFoundException: grails.plugin.spock.test.GrailsSpecTestType (Use --stacktrace to see the full trace)


In my BuildConfig.groovy I have:

    grails.project.dependency.resolution = {
       
...
        plugins
{
           
...
            test
":spock:0.7"
       
}
   
}


I've tried replacing it with compile ":spock:0.7" . 
I've also tried cleaning the application and refreshing the dependencies but no luck.

Any ideas what it could be and how I could fix it?

Thanks

--
You received this message because you are subscribed to the Google Groups "Spock Framework - User" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/spockframework.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Grails 2.3.9 - Error: ClassNotFoundException: grails.plugin.spock.test.GrailsSpecTestType

Peter Niederwieser
Administrator
Grails 2.3 and higher have Spock support built in, and the plugin is no longer required. See: https://objectpartners.com/2013/10/08/migrating-to-grails-2-3/

Cheers,
Peter

On 19 Jun 2015, at 20:01, Igor Alves <[hidden email]> wrote:

Hello there,

I wonder if someone can help me with this:

Whenever I enter the grails command: test-app I get this error:

    Error executing script TestApp: java.lang.ClassNotFoundException: grails.plugin.spock.test.GrailsSpecTestType (Use --stacktrace to see the full trace)


In my BuildConfig.groovy I have:

    grails.project.dependency.resolution = {
        ...
        plugins {
            ...
            test ":spock:0.7"
        }
    }


I've tried replacing it with compile ":spock:0.7" . 
I've also tried cleaning the application and refreshing the dependencies but no luck.

Any ideas what it could be and how I could fix it?

Thanks

--
You received this message because you are subscribed to the Google Groups "Spock Framework - User" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/spockframework.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Spock Framework - User" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/spockframework.
For more options, visit https://groups.google.com/d/optout.

signature.asc (859 bytes) Download Attachment
Loading...